TYPO3 CMS Authentication Bypass vulnerabilityGHSA-x4rj-f7m6-42c3
HIGHGHSA-x4rj-f7m6-42c3 is a high-severity (CVSS 7.5) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that TYPO3’s Salted Password system extension (which is a mandatory system component) is vulnerable to Authentication Bypass when using hashing methods which are related by PHP class inheritance. In standard TYPO3 core distributions stored passwords using the blowfish hashing algorithm can be overridden when using MD5 as the default hashing algorithm by just knowing a valid username. Per default the Portable PHP hashing algorithm (PHPass) is used which is not vulnerable.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.17 | 8.7.17composer require typo3/cms-core:^8.7.17 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.3.2 | 9.3.2composer require typo3/cms-core:^9.3.2 |
| 🐘Packagist | typo3/cms-core | ≥ 7.0.0&&< 7.6.30 | 7.6.30composer require typo3/cms-core:^7.6.30 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x4rj-f7m6-42c3 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-x4rj-f7m6-42c3 in your dependencies?
Find it across Packagist, including transitive dependencies.