NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

TYPO3 Arbitrary Code Execution and Cross-Site Scripting in Backend APIGHSA-x428-565f-8xj2

HIGHFix: TYPO3-CMS/core@3a99a08

GHSA-x428-565f-8xj2 is a high-severity (CVSS 8.8) remote code execution vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 6, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Backend API configuration using Page TSconfig is vulnerable to arbitrary code execution and cross-site scripting. TSconfig fields of page properties in backend forms can be used to inject malicious sequences. Field tsconfig_includes is vulnerable to directory traversal leading to same scenarios as having direct access to TSconfig settings.

A valid backend user account having access to modify values for fields pages.TSconfig and pages.tsconfig_includes is needed in order to exploit this vulnerability.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 8.0.0&&< 8.7.278.7.27composer require typo3/cms-core:^8.7.27
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.5.89.5.8composer require typo3/cms-core:^9.5.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 8.7.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x428-565f-8xj2 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Backend API configuration using Page TSconfig is vulnerable to arbitrary code execution and cross-site scripting. TSconfig fields of page properties in backend forms can be used to inject malicious sequences. Field tsconfig_includes is vulnerable to directory traversal leading to same scenarios as having direct access to TSconfig settings. A valid backend user account having access to modify values for fields `pages.TSconfig` and `pages.tsconfig_includes` is needed in order to exploit this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-x428-565f-8xj2 in your dependencies?

Find it across Packagist, including transitive dependencies.

TYPO3 Arbitrary Code Execution and Cross-Site Scripting…