NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Denial-of-service possibility in logout() view by filling session storeGHSA-x38m-486c-2wr9

HIGHFix: django/django@2f54853

GHSA-x38m-486c-2wr9 is a high-severity (CVSS 7.5) CWE-399 vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Also known asCVE-2015-5964PYSEC-2015-23
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
3.87%4.40%4.93%5.47%4.4%5.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The (1) contrib.sessions.backends.base.SessionBase.flush and (2) cache_db.SessionStore.flush functions in Django 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions create empty sessions in certain circumstances, which allows remote attackers to cause a denial of service (session store consumption) via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 1.7&&< 1.7.101.7.10pip install --upgrade 'django==1.7.10'
🐍PyPIdjango≥ 1.4&&< 1.4.221.4.22pip install --upgrade 'django==1.4.22'

Affected Products

3 products · 43 configurations
OS
ubuntu linuxcanonical
3 versions
12.0414.0415.04
Application
djangodjangoproject
33 versions
1.41.4.11.4.21.4.41.4.51.4.61.4.71.4.81.4.91.4.101.4.111.4.12
OS
solarisoracle
1 version
11.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 1.7.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-x38m-486c-2wr9 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6python-django-0:1.6.11-3.el6ostRHSA-2015:1766
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-0:1.6.11-3.el7ostRHSA-2015:1767
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7python-django-0:1.6.11-3.el7ostRHSA-2015:1894

Frequently Asked Questions

The (1) `contrib.sessions.backends.base.SessionBase.flush` and (2) `cache_db.SessionStore.flush` functions in Django 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions create empty sessions in certain circumstances, which allows remote attackers to cause a denial of service (session store consumption) via unspecified vectors.
O3 Security · Impact-Aware SCA

Is GHSA-x38m-486c-2wr9 in your dependencies?

Find it across PyPI, including transitive dependencies.

Denial-of-service possibility in logout() view by filling…