GHSA-wxcp-f2c8-x6xv is a medium-severity (CVSS 5.9) CWE-203 vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-wxcp-f2c8-x6xv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The Realm implementations in Apache Tomcat versions 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 did not process the supplied password if the supplied user name did not exist. This made a timing attack possible to determine valid user names. Note that the default configuration includes the LockOutRealm which makes exploitation of this vulnerability harder.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0M1&&< 9.0.0.M10 | 9.0.0.M10org.apache.tomcat:tomcat:9.0.0.M10 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.5.0&&< 8.5.5 | 8.5.5org.apache.tomcat:tomcat:8.5.5 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0.RC1&&< 8.0.37 | 8.0.37org.apache.tomcat:tomcat:8.0.37 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.72 | 7.0.72org.apache.tomcat:tomcat:7.0.72 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.46 | 6.0.46org.apache.tomcat:tomcat:6.0.46 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianoncommand insightnetapponcommand shiftnetappsnap creator frameworknetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 9.0.0.M10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wxcp-f2c8-x6xv is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.76-2.el7 | RHSA-2017:2247 |
| Red Hat JBoss Web Server 3.1 | see advisory | RHSA-2017:0457 |
| Red Hat JBoss Web Server 3 for RHEL 6 | hibernate4-eap6-0:4.2.23-1.Final_redhat_1.1.ep6.el6 | RHSA-2017:0455 |
| Red Hat JBoss Web Server 3 for RHEL 7 | hibernate4-eap6-0:4.2.23-1.Final_redhat_1.1.ep6.el7 | RHSA-2017:0456 |
Frequently Asked Questions
Is GHSA-wxcp-f2c8-x6xv in your dependencies?
Find it across Maven, including transitive dependencies.