NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

mxGraph vulnerable to XXE attacksGHSA-wvpv-8524-wg6x

CRITICALFix: jgraph/mxgraph@97b3718

GHSA-wvpv-8524-wg6x is a critical-severity (CVSS 9.8) XML External Entity (XXE) vulnerability in mxgraph. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mxgraph — see the affected versions and patch details below.

Also known asCVE-2017-18197
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.00%1.26%2.51%3.77%0.4%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

mxgraphnpm
24Kdownloads / week

Description

In mxGraphViewImageReader.java in mxGraph before 3.7.6, the SAXParserFactory instance in convert() is missing flags to prevent XML External Entity (XXE) attacks, as demonstrated by /ServerView.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmxgraphall versions3.7.6npm install mxgraph@3.7.6

Affected Products

1 product · 1 configurations
Application
mxgraphjgraph
≤ 3.7.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mxgraph, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mxgraph to 3.7.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wvpv-8524-wg6x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In `mxGraphViewImageReader.java` in mxGraph before 3.7.6, the `SAXParserFactory` instance in `convert()` is missing flags to prevent XML External Entity (XXE) attacks, as demonstrated by `/ServerView`.
O3 Security · Impact-Aware SCA

Is GHSA-wvpv-8524-wg6x in your dependencies?

Find it across npm, including transitive dependencies.

mxGraph vulnerable to XXE attacks (Critical 9.8)