TYPO3 Information Disclosure in User AuthenticationGHSA-wj85-rg5g-v8jm
MEDIUMFix: TYPO3-CMS/core@ac0565bGHSA-wj85-rg5g-v8jm is a medium-severity (CVSS 5.3) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that login failures have been logged on the default stream with log level "warning" including plain-text user credentials.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.6 | 9.5.6composer require typo3/cms-core:^9.5.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 9.5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wj85-rg5g-v8jm is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-wj85-rg5g-v8jm in your dependencies?
Find it across Packagist, including transitive dependencies.