Out-of-bounds write in nix::unistd::getgrouplistGHSA-wgrg-5h56-jg27
GHSA-wgrg-5h56-jg27 is a Out-of-bounds Write vulnerability in nix. A fix is available for nix — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
nix🦀nix🦀nixReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
On certain platforms, if a user has more than 16 groups, the
nix::unistd::getgrouplist function will call the libc getgrouplist
function with a length parameter greater than the size of the buffer it
provides, resulting in an out-of-bounds write and memory corruption.
The libc getgrouplist function takes an in/out parameter ngroups
specifying the size of the group buffer. When the buffer is too small to
hold all of the reqested user's group memberships, some libc
implementations, including glibc and Solaris libc, will modify ngroups
to indicate the actual number of groups for the user, in addition to
returning an error. The version of nix::unistd::getgrouplist in nix
0.16.0 and up will resize the buffer to twice its size, but will not
read or modify the ngroups variable. Thus, if the user has more than
twice as many groups as the initial buffer size of 8, the next call to
getgrouplist will then write past the end of the buffer.
The issue would require editing /etc/groups to exploit, which is usually only editable by the root user.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | nix | ≥ 0.16.0&&< 0.20.2 | 0.20.2cargo update -p nix --precise 0.20.2 |
| 🦀crates.io | nix | ≥ 0.21.0&&< 0.21.2 | 0.21.2cargo update -p nix --precise 0.21.2 |
| 🦀crates.io | nix | ≥ 0.22.0&&< 0.22.2 | 0.22.2cargo update -p nix --precise 0.22.2 |
Affected Products
nixnix_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nix, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nix to 0.20.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wgrg-5h56-jg27 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-wgrg-5h56-jg27 in your dependencies?
Find it across crates.io, including transitive dependencies.