TYPO3 Cross-Site Scripting in Online Media Asset RenderingGHSA-wg8h-gxf4-g4gh
MEDIUMFix: TYPO3-CMS/core@2380085GHSA-wg8h-gxf4-g4gh is a medium-severity (CVSS 6.1) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Failing to properly encode user input, online media asset rendering (*.youtube and *.vimeo files) is vulnerable to cross-site scripting. A valid backend user account or write access on the server system (e.g. SFTP) is needed in order to exploit this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.21 | 8.7.21composer require typo3/cms-core:^8.7.21 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.2 | 9.5.2composer require typo3/cms-core:^9.5.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wg8h-gxf4-g4gh is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-wg8h-gxf4-g4gh in your dependencies?
Find it across Packagist, including transitive dependencies.