NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

pocketmine/raklib reliable-ordered queue size is unlimited, allowing a session to hog server memoryGHSA-w98g-5fmx-wm4x

MEDIUMFix: pmmp/RakLib@371190f

GHSA-w98g-5fmx-wm4x is a medium-severity (CVSS 5.3) vulnerability in pocketmine/raklib. A fix is available for pocketmine/raklib — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 28, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘pocketmine/raklib🐘pocketmine/raklib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A client can send reliable-ordered packets 0, 2, 3, 4, 5 ... etc, and all the packets 2 and up will stay in the reliable-ordered queue until 1 arrives. A malicious client can exploit this to waste all available server memory by simply never sending the missing packet. Since the server doesn't make any effort to limit the size of the queue or detect this kind of abuse, this problem is easy to abuse.

Patches

This bug was fixed on the 0.14.x and 0.15.x release lines by 371190f5854372154d1b263cd2a10e658e92bebe.

Workarounds

No workaround is known.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistpocketmine/raklib≥ 0.14.0&&< 0.14.60.14.6composer require pocketmine/raklib:^0.14.6
🐘Packagistpocketmine/raklib≥ 0.15.0&&< 0.15.10.15.1composer require pocketmine/raklib:^0.15.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pocketmine/raklib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pocketmine/raklib to 0.14.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w98g-5fmx-wm4x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A client can send reliable-ordered packets 0, 2, 3, 4, 5 ... etc, and all the packets 2 and up will stay in the reliable-ordered queue until 1 arrives. A malicious client can exploit this to waste all available server memory by simply never sending the missing packet. Since the server doesn't make any effort to limit the size of the queue or detect this kind of abuse, this problem is easy to abuse. ### Patches This bug was fixed on the 0.14.x and 0.15.x release lines by 371190f5854372154d1b263cd2a10e658e92bebe. ### Workarounds No workaround is known.
O3 Security · Impact-Aware SCA

Is GHSA-w98g-5fmx-wm4x in your dependencies?

Find it across Packagist, including transitive dependencies.

GHSA-w98g-5fmx-wm4x: raklib — Fixed in 0.14.6