dbt-common's commonprefix() doesn't protect against path traversalGHSA-w75w-9qv4-j5xj
Fix: pypa/pip#13777GHSA-w75w-9qv4-j5xj is a Path Traversal vulnerability in dbt-common. A fix is available for dbt-common — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-w75w-9qv4-j5xj.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
dbt-common🐍dbt-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
What kind of vulnerability is it? Who is impacted?
A path traversal vulnerability exists in dbt-common's safe_extract() function used when extracting tarball archives. The function uses os.path.commonprefix() to validate that extracted files remain within the intended destination directory. However, commonprefix() compares paths character-by-character rather than by path components, allowing a malicious tarball to write files to sibling directories with matching name prefixes.
For example, when extracting to /tmp/packages, a crafted tarball could write files to /tmp/packagesevil/ by exploiting the character-based prefix matching.
This vulnerability affects users who:
- Install dbt packages from untrusted sources
- Process tarball archives through dbt-common's extraction utilities
The practical risk is limited because:
- Exploitation requires a malicious tarball to be processed
- File writes are restricted to sibling directories with matching prefixes (not arbitrary paths)
- Packages from trusted sources (dbt Hub) are not affected
This is similar to CVE-2026-1703 in pip, which had a CVSS score of 3.9 (Low).
Patches
Has the problem been patched? What versions should users upgrade to?
Fixed in dbt-common version 1.37.3 & 1.34.2, and patched for dbt-core 1.11.7 and 1.10.20 releases.
The fix replaces os.path.commonprefix() with os.path.commonpath(), which correctly compares paths by their components rather than characters.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
- Only install dbt packages from trusted sources (official dbt Hub, verified git repositories)
- Avoid installing packages from untrusted URLs or unverified third parties
- Review package contents before installation when sourcing from external locations
Resources
Are there any links users can visit to find out more?
- CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'): https://cwe.mitre.org/data/definitions/22.html
- CVE-2026-1703 (similar vulnerability in pip): https://nvd.nist.gov/vuln/detail/CVE-2026-1703
- pip fix PR #13777: https://github.com/pypa/pip/pull/13777
- Python documentation on
commonpathvscommonprefix: https://docs.python.org/3/library/os.path.html#os.path.commonpath
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | dbt-common | all versions | 1.34.2pip install --upgrade 'dbt-common==1.34.2' |
| 🐍PyPI | dbt-common | ≥ 1.35.0&&< 1.37.3 | 1.37.3pip install --upgrade 'dbt-common==1.37.3' |
Affected Products
dbt-commongetdbtDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dbt-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dbt-common to 1.34.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w75w-9qv4-j5xj is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is GHSA-w75w-9qv4-j5xj in your dependencies?
Find it across PyPI, including transitive dependencies.