NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
CRITICAL severity

Dynamic Linq vulnerable to remote code executionGHSA-w65q-jcmv-28gj

CRITICAL

GHSA-w65q-jcmv-28gj is a critical-severity (CVSS 9.8) CWE-697 vulnerability in System.Linq.Dynamic.Core. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for System.Linq.Dynamic.Core — see the affected versions and patch details below.

Also known asCVE-2023-32571
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-w65q-jcmv-28gj.

EPSS Exploitation Probability

via FIRST.org ↗
34.9%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
22.3%44.7%67.1%89.5%76.9%34.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETSystem.Linq.Dynamic.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Dynamic Linq 1.0.7.10 through 1.2.25 before 1.3.0 allows attackers to execute arbitrary code and commands when untrusted input to methods including Where, Select, OrderBy is parsed.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetSystem.Linq.Dynamic.Core≥ 1.0.7.10&&< 1.3.01.3.0dotnet add package System.Linq.Dynamic.Core --version 1.3.0

Affected Products

1 product · 1 configurations
Application
linqdynamic-linq
≥ 1.0.7.10 && ≤ 1.2.25
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for System.Linq.Dynamic.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update System.Linq.Dynamic.Core to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w65q-jcmv-28gj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Dynamic Linq 1.0.7.10 through 1.2.25 before 1.3.0 allows attackers to execute arbitrary code and commands when untrusted input to methods including Where, Select, OrderBy is parsed.
O3 Security · Impact-Aware SCA

Is GHSA-w65q-jcmv-28gj in your dependencies?

Find it across NuGet, including transitive dependencies.

Dynamic Linq vulnerable to remote code execution