NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malwareGHSA-w62p-hx95-gf2c

GHSA-w62p-hx95-gf2c is a CWE-506 vulnerability in duckdb. A fix is available for duckdb — see the affected versions and patch details below.

Also known asCVE-2025-59037
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-w62p-hx95-gf2c.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs31th percentile — riskier than 31% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

98other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
duckdbnpm
291Kdownloads / week
@duckdb/node-apinpm
3.3Mdownloads / week
@duckdb/node-bindingsnpm
3.2Mdownloads / week

Description

The DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of duckdb’s packages that included malicious code to interfere with cryptocoin transactions. The following packages and versions are affected:

Note: The current release version of DuckDB is 1.3.2, with 1.4.0 expected to be released on Sept 10th, 2025 (tomorrow as of this writing). We do not plan to ever release a “legit” DuckDB 1.3.3. Users should double-check that they are not accidentally updating to those affected versions.

We have ourselves noticed this within four hours of it happening. Here’s our response:

  • As an immediate response, we have deprecated the specific versions.
  • We have reached out to npm support to delete the affected versions. They were so kind to do so.
  • We have also re-released the node packages with higher version numbers (1.3.4/1.30.0) as a further safeguard so the latest version of the package points to a safe version

We apologize for this issue. We are reviewing our internal processes to ensure the safety of future releases.

Postmortem

On September 8th (Monday), the DuckDB maintainers received the following message from "[email protected]":

<img width="1134" height="614" alt="Screenshot 2025-09-09 at 11 07 09" src="https://github.com/user-attachments/assets/0ce24798-1f5a-40b0-ac50-49035d99862b" />

One of the maintainers read through this text and found it somewhat reasonable. He followed the link (now defunct) to a website hosted under the domain npmjs.help. This website contained a pixel-perfect copy of the npmjs.com website. He logged in using the duckdb_admin user and password, followed by 2FA. Again, the user profile, settings etc. were a perfect copy of the npmjs.com website including all user data. As requested by the email, he then re-set the 2FA setup.

In the background, the copycat website forwarded all actions to the actual npm website, so the 2FA was actually updated there, too. But they also added a new API token, which they then used to publish the malicious package versions. In hindsight, the fact that his browser did not auto-complete the login should have been a red flag. It's painful to spell out, but we fell for a classic phishing attack.

We again apologize for this mishap. We are reviewing our internal processes to ensure the safety of future releases. It is fortunate that we noticed this within a few hours of it happening. The DuckDBLabs team was able to set up a call at 7AM to perform an immediate response. Fortunately we were not locked out of our NPM account, which also easily could have happened. We were able to rotate passwords, tokens and API keys immediately.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmduckdb≥ 1.3.3&&< 1.3.41.3.4npm install duckdb@1.3.4
📦npm@duckdb/node-api≥ 1.3.3&&< 1.3.4-alpha.271.3.4-alpha.27npm install @duckdb/node-api@1.3.4-alpha.27
📦npm@duckdb/node-bindings≥ 1.3.3&&< 1.3.4-alpha.271.3.4-alpha.27npm install @duckdb/node-bindings@1.3.4-alpha.27
📦npm@duckdb/duckdb-wasm≥ 1.29.2&&< 1.30.01.30.0npm install @duckdb/duckdb-wasm@1.30.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for duckdb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update duckdb to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w62p-hx95-gf2c is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The DuckDB distribution for [Node.js](http://node.js/) on [npm](https://www.npmjs.com/) was compromised with malware (along with [several other packages](https://www.aikido.dev/blog/npm-debug-and-chalk-packages-compromised)). An attacker published new versions of four of duckdb’s packages that included **malicious code to interfere with cryptocoin transactions**. The following packages and versions are affected: - `@duckdb/[email protected]` - `@duckdb/[email protected]` - `[email protected]` - `@duckdb/[email protected]` > Note: The current release version of DuckDB is 1.3.2, with 1.4.0 expected
O3 Security · Impact-Aware SCA

Is GHSA-w62p-hx95-gf2c in your dependencies?

Find it across npm, including transitive dependencies.

DuckDB NPM packages 1.3.3 and 1.29.2 briefly…