imageproc: integer overflow in kernel size check leads to out-of-bounds readGHSA-w5p8-4jcx-2j6r
GHSA-w5p8-4jcx-2j6r is a remote code execution vulnerability in imageproc. A fix is available for imageproc — see the affected versions and patch details below.
Real-World Exposure
imageproc🦀imageproc🦀imageproc🦀imageprocReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
A bounds verification of a slice storage of a 2-dimensional matrix's coefficients (a kernel) would compare the total size against the product of individual dimensions. This would erroneously cast after the multiplication and consequently fail to detect possible violations when overflow occurs.
Afterwards, the individual sizes were trusted to properly constrain coordinates within the matrix to indices valid for the underlying storage. With a crafted Kernel object, certain combinations of coordinates could then cause an out-of-bounds access in an unsafe function while fulfilling its documented preconditions. The kernel value could be passed to library functions that trusted the preconditions and then performed such reads.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | imageproc | all versions | 0.23.1cargo update -p imageproc --precise 0.23.1 |
| 🦀crates.io | imageproc | ≥ 0.24.0&&< 0.24.1 | 0.24.1cargo update -p imageproc --precise 0.24.1 |
| 🦀crates.io | imageproc | ≥ 0.25.0&&< 0.25.1 | 0.25.1cargo update -p imageproc --precise 0.25.1 |
| 🦀crates.io | imageproc | ≥ 0.26.0&&< 0.26.2 | 0.26.2cargo update -p imageproc --precise 0.26.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for imageproc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update imageproc to 0.23.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w5p8-4jcx-2j6r is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-w5p8-4jcx-2j6r in your dependencies?
Find it across crates.io, including transitive dependencies.