NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

openstack-neutron uncontrolled resource consumption flawGHSA-w446-h7vg-wv3p

MEDIUMFix: openstack/neutron@01fc2b9

GHSA-w446-h7vg-wv3p is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in neutron. A fix is available for neutron — see the affected versions and patch details below.

Also known asCVE-2022-3277PYSEC-2026-855
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-w446-h7vg-wv3p.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.57%0.4%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍neutron🐍neutron🐍neutron

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An uncontrolled resource consumption flaw was found in openstack-neutron. This flaw allows a remote authenticated user to query a list of security groups for an invalid project. This issue creates resources that are unconstrained by the user's quota. If a malicious user were to submit a significant number of requests, this could lead to a denial of service.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIneutron≥ 19.0.0.0rc1&&< 19.5.019.5.0pip install --upgrade 'neutron==19.5.0'
🐍PyPIneutronall versions18.6.0pip install --upgrade 'neutron==18.6.0'
🐍PyPIneutron≥ 20.0.0.0rc1&&< 20.3.020.3.0pip install --upgrade 'neutron==20.3.0'

Affected Products

2 products · 5 configurations
Application
neutronopenstack
≥ 19.0.0 && < 19.5.0
range
Application
openstack platformredhat
3 versions
13.016.116.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neutron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update neutron to 19.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-w446-h7vg-wv3p is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

While this vulnerability triggers the usage of API and Database resources, there is no action taken by OpenStack to enforce these new security group rules. As a result, the impact of this Denial of Service is rather limited. So deployments that have a strong trust relationship with all users (such as a private or…

ProductFixed inAdvisory
Red Hat OpenStack Platform 16.1openstack-neutron-1:15.2.1-1.20221005123225.40d217c.el8ostRHSA-2022:8870
Red Hat OpenStack Platform 16.2openstack-neutron-1:15.3.5-2.20221005184727.c81fb5b.el8ostRHSA-2022:8855
Red Hat OpenStack Platform 17.0openstack-neutron-1:18.4.1-0.20221128170741.5258354.el9ostRHSA-2023:0275

Frequently Asked Questions

An uncontrolled resource consumption flaw was found in openstack-neutron. This flaw allows a remote authenticated user to query a list of security groups for an invalid project. This issue creates resources that are unconstrained by the user's quota. If a malicious user were to submit a significant number of requests, this could lead to a denial of service.
O3 Security · Impact-Aware SCA

Is GHSA-w446-h7vg-wv3p in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-w446-h7vg-wv3p: neutron DoS — Fixed in 19.5.0