Dolibarr remote PHP code executionGHSA-vxr9-p2xw-m8cf
CRITICALGHSA-vxr9-p2xw-m8cf is a critical-severity (CVSS 9.8) Code Injection vulnerability in dolibarr/dolibarr. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for dolibarr/dolibarr — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dolibarr/dolibarrReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The website builder module in Dolibarr 13.0.2 allows remote PHP code execution because of an incomplete protection mechanism in which system, exec, and shell_exec are blocked but backticks are not blocked.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dolibarr/dolibarr | ≥ 13.0.2&&< 14.0.0 | 14.0.0composer require dolibarr/dolibarr:^14.0.0 |
Affected Products
dolibarr erp\/crmdolibarrResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dolibarr/dolibarr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dolibarr/dolibarr to 14.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vxr9-p2xw-m8cf is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-vxr9-p2xw-m8cf in your dependencies?
Find it across Packagist, including transitive dependencies.