GHSA-vwhw-vp9v-q9c9 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-vwhw-vp9v-q9c9.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in mooodle. A remote attacker could exploit a reflected Cross-Site Scripting (XSS) vulnerability in the policy tool return URL. This vulnerability arises from insufficient sanitization of URL parameters, allowing attackers to inject malicious scripts through specially crafted links. Successful exploitation could lead to information disclosure or arbitrary client-side script execution within the user's browser.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 4.1.22composer require moodle/moodle:^4.1.22 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.12 | 4.4.12composer require moodle/moodle:^4.4.12 |
| 🐘Packagist | moodle/moodle | ≥ 4.5.0-beta&&< 4.5.8 | 4.5.8composer require moodle/moodle:^4.5.8 |
| 🐘Packagist | moodle/moodle | ≥ 5.0.0-beta&&< 5.0.4 | 5.0.4composer require moodle/moodle:^5.0.4 |
| 🐘Packagist | moodle/moodle | ≥ 5.1.0-beta&&< 5.1.1 | 5.1.1composer require moodle/moodle:^5.1.1 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vwhw-vp9v-q9c9 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-vwhw-vp9v-q9c9 in your dependencies?
Find it across Packagist, including transitive dependencies.