Laravel Cross-site Scripting (XSS) vulnerability in blade templatingGHSA-vr95-p7q6-8m9q
MEDIUMFix: laravel/framework#31945GHSA-vr95-p7q6-8m9q is a medium-severity (CVSS 4.3) vulnerability in laravel/framework. A fix is available for laravel/framework — see the affected versions and patch details below.
Real-World Exposure
laravel/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Laravel 7.1.2 addresses a possible XSS related attack vector in the Laravel 7.x Blade Component tag attributes when users are allowed to dictate the value of attributes. All Laravel 7.x users are encouraged to upgrade as soon as possible.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | laravel/framework | ≥ 7.0.0&&< 7.1.2 | 7.1.2composer require laravel/framework:^7.1.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for laravel/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update laravel/framework to 7.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vr95-p7q6-8m9q is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-vr95-p7q6-8m9q in your dependencies?
Find it across Packagist, including transitive dependencies.