Out of bounds read in bumpaloGHSA-vqx7-pw4r-29rr
HIGHGHSA-vqx7-pw4r-29rr is a high-severity (CVSS 7.5) Out-of-bounds Read vulnerability in bumpalo. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for bumpalo — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
bumpaloReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the bumpalo crate before 3.2.1 for Rust. The realloc feature allows the reading of unknown memory. Attackers can potentially read cryptographic keys.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | bumpalo | ≥ 3.0.0&&< 3.2.1 | 3.2.1cargo update -p bumpalo --precise 3.2.1 |
Affected Products
bumpalobumpalo_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bumpalo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bumpalo to 3.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vqx7-pw4r-29rr is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-vqx7-pw4r-29rr in your dependencies?
Find it across crates.io, including transitive dependencies.