NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Openstack Manila Persistent XSS in Metadata fieldGHSA-vq76-5ghr-9p4v

MEDIUMFix: openstack/manila-ui@009913d

GHSA-vq76-5ghr-9p4v is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in manila-ui. A fix is available for manila-ui — see the affected versions and patch details below.

Also known asCVE-2016-6519PYSEC-2026-662
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.66%1.32%1.97%0.3%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍manila-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the "Shares" overview in Openstack Manila before 2.5.1 allows remote authenticated users to inject arbitrary web script or HTML via the Metadata field in the "Create Share" form.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImanila-uiall versions2.5.1pip install --upgrade 'manila-ui==2.5.1'

Affected Products

2 products · 4 configurations
Application
manilaopenstack
≤ 2.5
range
Application
openstackredhat
3 versions
7.089

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for manila-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update manila-ui to 2.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vq76-5ghr-9p4v is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7openstack-manila-ui-0:1.0.1-3.el7ostRHSA-2016:2115
Red Hat OpenStack Platform 8.0 (Liberty)openstack-manila-ui-0:1.2.0-2.el7ostRHSA-2016:2116
Red Hat OpenStack Platform 9.0 (Mitaka)openstack-manila-ui-0:2.1.0-2.el7ostRHSA-2016:2117

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the "Shares" overview in Openstack Manila before 2.5.1 allows remote authenticated users to inject arbitrary web script or HTML via the Metadata field in the "Create Share" form.
O3 Security · Impact-Aware SCA

Is GHSA-vq76-5ghr-9p4v in your dependencies?

Find it across PyPI, including transitive dependencies.

Openstack Manila Persistent XSS in Metadata field