Thelia Cross-site Scripting vulnerability in BackOfficeGHSA-vq4j-qcx7-ppc6
MEDIUMFix: thelia/thelia@e7c9c3bGHSA-vq4j-qcx7-ppc6 is a medium-severity (CVSS 6.1) vulnerability in thelia/thelia. A fix is available for thelia/thelia — see the affected versions and patch details below.
Real-World Exposure
thelia/theliaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The BackOffice of Thelia (error.html template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | thelia/thelia | ≥ 2.1.0&&< 2.1.2 | 2.1.2composer require thelia/thelia:^2.1.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thelia/thelia, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update thelia/thelia to 2.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vq4j-qcx7-ppc6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-vq4j-qcx7-ppc6 in your dependencies?
Find it across Packagist, including transitive dependencies.