Sharp Missing Authorization Check in Quick Creation Command EndpointsGHSA-vmwx-m75v-qvch
MEDIUMFix: code16/sharp#729GHSA-vmwx-m75v-qvch is a medium-severity (CVSS 4.3) CWE-862 vulnerability in code16/sharp. A fix is available for code16/sharp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-vmwx-m75v-qvch.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
code16/sharpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The create and store endpoints of the Quick Creation Command feature did not enforce any authorization check. An authenticated Sharp user without create permission on a given entity could bypass the authorization layer and either retrieve the creation form or submit new records for that entity, as long as it had a Quick Creation Command handler configured.
Patches
Yes. The fix is included in version 9.22.3. Users should upgrade to that version or later.
Workarounds
Remove or disable Quick Creation Command handlers (quickCreationCommandHandler()) on any entity list where unauthorized access is a concern, until an upgrade is possible.
Resources
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | code16/sharp | ≥ 9.0.0&&< 9.22.3 | 9.22.3composer require code16/sharp:^9.22.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for code16/sharp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update code16/sharp to 9.22.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vmwx-m75v-qvch is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-vmwx-m75v-qvch in your dependencies?
Find it across Packagist, including transitive dependencies.