NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Qwik City CSRF protection middleware does not work properly for content type header with parameters (eg. multipart/form-data)GHSA-vm6g-8r4h-22x8

MEDIUMFix: QwikDev/qwik@d70d709

GHSA-vm6g-8r4h-22x8 is a medium-severity (CVSS 5.9) Cross-Site Request Forgery (CSRF) vulnerability in @builder.io/qwik-city. A fix is available for @builder.io/qwik-city — see the affected versions and patch details below.

Also known asCVE-2026-25155
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-vm6g-8r4h-22x8.

EPSS Exploitation Probability

via FIRST.org ↗
0.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs4th percentile — riskier than 4% of all scored CVEsHighest risk
0.00%0.22%0.43%0.65%0.0%0.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

9other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@builder.io/qwik-citynpm
47Kdownloads / week

Description

Summary

A typo in the regular expression within isContentType causes incorrect parsing of certain Content-Type headers.

Impact

An attacker can bypass Qwik City’s Origin-based CSRF protections and perform forged form submissions, potentially causing unauthorized state changes.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@builder.io/qwik-cityall versions1.12.0npm install @builder.io/qwik-city@1.12.0

Affected Products

1 product · 1 configurations
Application
qwikqwik
< 1.12.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @builder.io/qwik-city, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @builder.io/qwik-city to 1.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vm6g-8r4h-22x8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary A typo in the regular expression within isContentType causes incorrect parsing of certain Content-Type headers. ### Impact An attacker can bypass Qwik City’s Origin-based CSRF protections and perform forged form submissions, potentially causing unauthorized state changes.
O3 Security · Impact-Aware SCA

Is GHSA-vm6g-8r4h-22x8 in your dependencies?

Find it across npm, including transitive dependencies.

Qwik City CSRF protection middleware does not work…