SFTPGo has insufficient sanitization of user provided rsync commandGHSA-vj7w-3m8c-6vpx
HIGHFix: drakkan/sftpgo@b347ab6GHSA-vj7w-3m8c-6vpx is a high-severity (CVSS 7.5) OS Command Injection vulnerability in github.com/drakkan/sftpgo/v2. A fix is available for github.com/drakkan/sftpgo/v2 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-vj7w-3m8c-6vpx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/drakkan/sftpgo/v2🐹github.com/drakkan/sftpgoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
SFTPGo is an open source, event-driven file transfer solution. SFTPGo supports execution of a defined set of commands via SSH. Besides a set of default commands some optional commands can be activated, one of them being rsync. It is disabled in the default configuration and it is limited to the local filesystem, it does not work with cloud/remote storage backends. Due to missing sanitization of the client provided rsync command, an authenticated remote user can use some options of the rsync command to read or write files with the permissions of the SFTPGo server process. This issue was fixed in version v2.6.5 by checking the client provided arguments. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/drakkan/sftpgo/v2 | ≥ 0.9.5&&< 2.6.5 | 2.6.5go get github.com/drakkan/sftpgo/v2@v2.6.5 |
| 🐹Go | github.com/drakkan/sftpgo | all versions | No fix |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/drakkan/sftpgo/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/drakkan/sftpgo/v2 to 2.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vj7w-3m8c-6vpx is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-vj7w-3m8c-6vpx in your dependencies?
Find it across Go, including transitive dependencies.