NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

node-opcua DoS when bypassing limitations for excessive memory consumptionGHSA-vh4f-fgpp-x8x2

HIGHFix: node-opcua/node-opcua#1182

GHSA-vh4f-fgpp-x8x2 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in node-opcua. A fix is available for node-opcua — see the affected versions and patch details below.

Also known asCVE-2022-24375
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.09%0.81%1.54%2.27%0.6%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

122other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
node-opcuanpm
97Kdownloads / week

Description

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription parameter equal to False.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnode-opcuaall versions2.74.0npm install node-opcua@2.74.0

Affected Products

1 product · 1 configurations
Application
node-opcuanode-opcua_project
< 2.74.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for node-opcua, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update node-opcua to 2.74.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vh4f-fgpp-x8x2 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple `CloseSession` requests with the `deleteSubscription` parameter equal to `False`.
O3 Security · Impact-Aware SCA

Is GHSA-vh4f-fgpp-x8x2 in your dependencies?

Find it across npm, including transitive dependencies.

node-opcua DoS when bypassing limitations for…