graphite.composer.views.send_email vulnerable to SSRFGHSA-vfj6-275q-4pvm
HIGHFix: graphite-project/graphite-web#2499GHSA-vfj6-275q-4pvm is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in graphite-web. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for graphite-web — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
graphite-webReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
send_email in graphite-web/webapp/graphite/composer/views.py in Graphite through 1.1.5 is vulnerable to SSRF. The vulnerable SSRF endpoint can be used by an attacker to have the Graphite web server request any resource. The response to this SSRF request is encoded into an image file and then sent to an e-mail address that can be supplied by the attacker. Thus, an attacker can exfiltrate any information. Email will be send through SMTP server configured in Graphite, by default it's 'localhost'
Patches
Problem was patched in Graphite-web 1.1.6. Also patches was released for graphite-web 1.0.x and 0.9.x, and we'll discuss releases of non-supported branches later.
Workarounds
You can manually remove function send_email from file webapp/graphite/composer/views.py. This function are not in use and will not affect your Graphite installation.
References
For more information check this graphite-web Github issue #2008
For more information
If you have any questions or comments about this advisory:
- Add comment in issue #2008
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | graphite-web | all versions | 1.1.6pip install --upgrade 'graphite-web==1.1.6' |
Affected Products
graphitegraphite_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for graphite-web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update graphite-web to 1.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vfj6-275q-4pvm is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
How to detect GHSA-vfj6-275q-4pvm
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-vfj6-275q-4pvm -u https://target- Template
- Graphite <=1.1.5 - Server-Side Request Forgery
- Severity
- high
- Impact
- An attacker can exploit this vulnerability to access internal resources, potentially leading to unauthorized access, data leakage, or further attacks.
- Remediation
- Upgrade to a patched version of Graphite (>=1.1.6) or apply the necessary security patches.
Template by ProjectDiscovery nuclei-templates (huowuzhao), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-vfj6-275q-4pvm in your dependencies?
Find it across PyPI, including transitive dependencies.