NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

OpenCloud Affected by Public Link ExploitGHSA-vf5j-r2hw-2hrw

HIGH

GHSA-vf5j-r2hw-2hrw is a high-severity (CVSS 8.2) vulnerability in github.com/opencloud-eu/opencloud. A fix is available for github.com/opencloud-eu/opencloud — see the affected versions and patch details below.

Also known asGO-2026-4447
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Feb 19, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐹github.com/opencloud-eu/opencloud🐹github.com/opencloud-eu/opencloud

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A security issue was discovered in Reva that enables a malicious user to bypass the scope validation of a public link. That allows it to access resources outside the scope of a public link.

OpenCloud uses Reva as one of its core components and thus it is affected.

Patches

Update to OpenCloud version >= 4.0.3 (stable release) Update to OpenCloud version >= 5.0.2 (rolling release)

Workarounds

If projects are unable to update immediately, please implement the following security configuration to disable public link shares temporarily until the final solution for this problem is rolled out.

Configuration Adjustment

  • Docker Compose: Edit the docker-compose.yml and add GATEWAY_STORAGE_PUBLIC_LINK_ENDPOINT=“” (empty string value) in the environment section of the opencloud container.

Verification of Mitigation

Execute the following test:

  • Create a public link for testing.
  • Open the link url in a private (no active login) browser tab.
  • An error page with “unknown error” will be displayed.

This configuration provides immediate protection and should be implemented immediately. Configuration mitigation is available. It mitigates the problem completely.

For more information

If there are questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/opencloud-eu/opencloud≥ 4.0.0&&< 4.0.34.0.3go get github.com/opencloud-eu/opencloud@v4.0.3
🐹Gogithub.com/opencloud-eu/opencloud≥ 5.0.0&&< 5.0.25.0.2go get github.com/opencloud-eu/opencloud@v5.0.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/opencloud-eu/opencloud, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/opencloud-eu/opencloud to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-vf5j-r2hw-2hrw is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A security issue was discovered in [Reva](https://github.com/opencloud-eu/reva) that enables a malicious user to bypass the scope validation of a public link. That allows it to access resources outside the scope of a public link. OpenCloud uses Reva as one of its core components and thus it is affected. ### Patches Update to OpenCloud version >= 4.0.3 (stable release) Update to OpenCloud version >= 5.0.2 (rolling release) ### Workarounds If projects are unable to update immediately, please implement the following security configuration to disable public link shares temporarily
O3 Security · Impact-Aware SCA

Is GHSA-vf5j-r2hw-2hrw in your dependencies?

Find it across Go, including transitive dependencies.

OpenCloud Affected by Public Link Exploit (High 8.2)