NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

mako is vulnerable to Regular Expression Denial of ServiceGHSA-v973-fxgf-6xhp

HIGHFix: sqlalchemy/mako@9257602

GHSA-v973-fxgf-6xhp is a high-severity (CVSS 7.5) CWE-1333 vulnerability in mako. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mako — see the affected versions and patch details below.

Also known asCVE-2022-40023PYSEC-2022-260
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.51%1.23%1.95%2.67%1.0%2.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mako

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImakoall versions1.2.2pip install --upgrade 'mako==1.2.2'

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
10.0
Application
makosqlalchemy
< 1.2.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mako, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mako to 1.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v973-fxgf-6xhp is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 8python-mako-0:1.0.6-14.el8RHSA-2023:2893
Red Hat Enterprise Linux 9python-mako-0:1.1.4-6.el9RHSA-2023:2258

Frequently Asked Questions

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
O3 Security · Impact-Aware SCA

Is GHSA-v973-fxgf-6xhp in your dependencies?

Find it across PyPI, including transitive dependencies.

mako is vulnerable to Regular Expression Denial of Service