ZITADEL Vulnerable to Account Takeover via DOM-Based XSS in Zitadel V2 LoginGHSA-v959-qxv6-6f8p
HIGHFix: zitadel/zitadel@4c879b4GHSA-v959-qxv6-6f8p is a high-severity (CVSS 8) Cross-site Scripting (XSS) vulnerability in github.com/zitadel/zitadel. A fix is available for github.com/zitadel/zitadel — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v959-qxv6-6f8p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel🐹github.com/zitadel/zitadel/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A potential vulnerability exists in ZITADEL's logout endpoint in login V2. This endpoint accepts serval parameters including a post_logout_redirect. When this parameter is specified, users will be redirected to the site that is provided via this parameter.
ZITADEL's login UI did not ensure that this parameter contained an allowed value and even executed passed scripts.
Impact
Zitadel is vulnerable to a DOM-Based XSS vulnerability. More specifically, the /logout endpoint insecurely routed to value that is supplied in the post_logout_redirect GET parameter. As a result, malicious JS code could be executed on Zitadel users’ browsers, in the Zitadel V2 Login domain.
An unauthenticated remote attacker can exploit this DOM-based XSS vulnerability, and thus, execute malicious JavaScript code on behalf of Zitadel users. By doing so, such an attacker could reset the password of their victims, and take over their accounts.
Note that for this to work, multiple user sessions need to be active in the same browser. Additionally, it's important to note that an account takeover is mitigated for accounts that have Multi-Factor Authentication (MFA) or Passwordless authentication enabled.
Affected Versions
Systems using the login UI (v2) and running one of the following versions are affected:
- v4.x:
4.0.0-rc.1through4.7.0
Patches
The vulnerability has been addressed in the latest release. The patch resolves the issue by ensuring the information was passed for the ZITADEL API using a JSON Web Token (JWT).
If you're running your own login UI, we recommend switching over to the new logout_token parameter, which contains all information previously passed via specific query parameters. The contained JWT's signature needs to be verified with the instance OAuth2/OIDC public keys (jwks_uri).
Before you upgrade, ensure that:
- the
ZITADEL_API_URLis set and is pointing to your instance, resp. system in multi-instance deployments. - the HTTP
host(or ax-forwarded-host) is passed in your reverse proxy to the login UI. - a
x-zitadel-instance-host(orx-zitadel-forward-host) is set in your reverse for multi-instance deployments. If you're running a single instance solution, you don't need to take any actions.
Patched versions:
- 4.x: Upgrade to >=4.7.1
Workarounds
The recommended solution is to update ZITADEL to a patched version.
Questions
If you have any questions or comments about this advisory, please email us at [email protected]
Credits
Thanks to Amit Laish – GE Vernova for finding and reporting the vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/zitadel/zitadel | all versions | 1.80.0-v2.20.0.20251208091519-4c879b47334ego get github.com/zitadel/zitadel@v1.80.0-v2.20.0.20251208091519-4c879b47334e |
| 🐹Go | github.com/zitadel/zitadel | ≥ 1.83.4 | No fix |
| 🐹Go | github.com/zitadel/zitadel | ≥ 4.0.0-rc.1&&< 4.7.1 | 4.7.1go get github.com/zitadel/zitadel@v4.7.1 |
| 🐹Go | github.com/zitadel/zitadel/v2 | all versions | 1.80.0-v2.20.0.20251208091519-4c879b47334ego get github.com/zitadel/zitadel/v2@v1.80.0-v2.20.0.20251208091519-4c879b47334e |
Affected Products
zitadelzitadelDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zitadel/zitadel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/zitadel/zitadel to 1.80.0-v2.20.0.20251208091519-4c879b47334e or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v959-qxv6-6f8p is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-v959-qxv6-6f8p in your dependencies?
Find it across Go, including transitive dependencies.