GHSA-v8hp-239v-9367 is a medium-severity (CVSS 6.1) vulnerability in oro/crm. A fix is available for oro/crm — see the affected versions and patch details below.
Real-World Exposure
oro/crmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
OroCRM is prone to open redirection which could allow attackers to redirect users to external website.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | oro/crm | ≥ 1.7.0&&< 1.7.4 | 1.7.4composer require oro/crm:^1.7.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oro/crm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update oro/crm to 1.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v8hp-239v-9367 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is GHSA-v8hp-239v-9367 in your dependencies?
Find it across Packagist, including transitive dependencies.