FUXA Unauthenticated Remote Code Execution in Node-RED IntegrationGHSA-v4p5-w6r3-2x4f
Fix: frangoteam/FUXA@5e7679bGHSA-v4p5-w6r3-2x4f is a CWE-290 vulnerability in fuxa-server. A fix is available for fuxa-server — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v4p5-w6r3-2x4f.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
fuxa-servernpmDescription
Summary
Description An authentication bypass vulnerability in FUXA allows an unauthenticated, remote attacker to execute arbitrary code on the server when the Node-RED plugin is enabled. This affects FUXA version 1.2.8 through version 1.2.10. This has been patched in FUXA version 1.2.11.
Impact
This affects all deployments with the Node-RED plugin enabled, including those with runtime.settings.secureEnabled set to true.
Exploitation allows an unauthenticated, remote attacker to send a specially crafted request to the /nodered/flows endpoint to bypass authentication checks, granting the attacker administrative access to the Node-RED deployment API. By submitting a malicious flow configuration, an attacker can execute arbitrary code in the context of the FUXA service. Depending on deployment configuration and permissions, this may lead to full system compromise and could further expose connected ICS/SCADA environments to follow-on actions.
Patches
This issue has been patched in FUXA version 1.2.11. Users are strongly encouraged to update to the latest available release.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | fuxa-server | ≥ 1.2.8&&< 1.2.11 | 1.2.11npm install fuxa-server@1.2.11 |
Affected Products
fuxafrangoteamDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fuxa-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fuxa-server to 1.2.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v4p5-w6r3-2x4f is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-v4p5-w6r3-2x4f in your dependencies?
Find it across npm, including transitive dependencies.