Apache NiFi: Potential Insertion of Sensitive Parameter Values in Debug LogGHSA-v3vc-6qcv-4vrx
Fix: apache/nifi@5aed878GHSA-v3vc-6qcv-4vrx is a CWE-532 vulnerability in org.apache.nifi:nifi-framework-core. A fix is available for org.apache.nifi:nifi-framework-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v3vc-6qcv-4vrx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.nifi:nifi-framework-core☕org.apache.nifi:nifi-framework-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache NiFi 1.16.0 through 1.28.0 and 2.0.0-M1 through 2.0.0-M4 include optional debug logging of Parameter Context values during the flow synchronization process. An authorized administrator with access to change logging levels could enable debug logging for framework flow synchronization, causing the application to write Parameter names and values to the application log. Parameter Context values may contain sensitive information depending on application flow configuration. Deployments of Apache NiFi with the default Logback configuration do not log Parameter Context values. Upgrading to Apache NiFi 2.0.0 or 1.28.1 is the recommendation mitigation, eliminating Parameter value logging from the flow synchronization process regardless of the Logback configuration.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.nifi:nifi-framework-core | ≥ 1.16.0&&< 1.28.1 | 1.28.1org.apache.nifi:nifi-framework-core:1.28.1 |
| ☕Maven | org.apache.nifi:nifi-framework-core | ≥ 2.0.0-M1&&< 2.0.0 | 2.0.0org.apache.nifi:nifi-framework-core:2.0.0 |
Affected Products
nifiapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.nifi:nifi-framework-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.nifi:nifi-framework-core to 1.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v3vc-6qcv-4vrx is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-v3vc-6qcv-4vrx in your dependencies?
Find it across Maven, including transitive dependencies.