llama_index vulnerable to SQL InjectionGHSA-v3c8-3pr6-gr7p
CRITICALFix: run-llama/llama_index@0008041GHSA-v3c8-3pr6-gr7p is a critical-severity (CVSS 9.8) SQL Injection vulnerability in llama-index. A fix is available for llama-index — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v3c8-3pr6-gr7p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
llama-indexReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilities. These vulnerabilities allow an attacker to read and write data using SQL, potentially leading to unauthorized access to data of other users depending on the usage of the llama-index library in a web application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | llama-index | all versions | 0.12.28pip install --upgrade 'llama-index==0.12.28' |
Affected Products
llamaindexllamaindexDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for llama-index, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update llama-index to 0.12.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v3c8-3pr6-gr7p is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Ansible LightSpeed does not use Ollama-index and is not installed in this image, therefore this product is not vulnerable by this flaw.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-v3c8-3pr6-gr7p (CC BY 4.0)
Frequently Asked Questions
Is GHSA-v3c8-3pr6-gr7p in your dependencies?
Find it across PyPI, including transitive dependencies.