Silverstripe GraphQL has DDOS Vulnerability due to lack of protection against recursive queriesGHSA-v23w-pppm-jh66
HIGHFix: silverstripe/silverstripe-graphql@f6d5976GHSA-v23w-pppm-jh66 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in silverstripe/graphql. A fix is available for silverstripe/graphql — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v23w-pppm-jh66.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/graphql🐘silverstripe/graphql🐘silverstripe/graphql🐘silverstripe/graphql🐘silverstripe/graphqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An attacker could use a recursive graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed graphql schemas.
If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this may further mitigate the risk.
The fix includes some new configuration options which you might want to tweak for your project, based on your own requirements. See the documentation in the references for details.
Patches
Patched in 3.8.2, 4.1.3, 4.2.5, 4.3.4, 5.0.3
References
- CVE-2023-40180 on silverstripe.org
- Documentation about protection against recursive or complex queries for silverstripe/graphql 4.x/5.x
- Documentation about protection against recursive or complex queries for silverstripe/graphql 3.x
Reported by
Jason Nguyen from phew (https://phew.co.nz/)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/graphql | ≥ 3.0.0&&< 3.8.2 | 3.8.2composer require silverstripe/graphql:^3.8.2 |
| 🐘Packagist | silverstripe/graphql | ≥ 4.0.0&&< 4.1.3 | 4.1.3composer require silverstripe/graphql:^4.1.3 |
| 🐘Packagist | silverstripe/graphql | ≥ 4.2.0&&< 4.2.5 | 4.2.5composer require silverstripe/graphql:^4.2.5 |
| 🐘Packagist | silverstripe/graphql | ≥ 4.3.0&&< 4.3.4 | 4.3.4composer require silverstripe/graphql:^4.3.4 |
| 🐘Packagist | silverstripe/graphql | ≥ 5.0.0&&< 5.0.3 | 5.0.3composer require silverstripe/graphql:^5.0.3 |
Affected Products
graphqlsilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/graphql to 3.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v23w-pppm-jh66 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-v23w-pppm-jh66 in your dependencies?
Find it across Packagist, including transitive dependencies.