TYPO3 Security Misconfiguration for Backend User AccountsGHSA-rxc9-f2x6-qh4w
HIGHFix: TYPO3-CMS/core@1e0c7a6GHSA-rxc9-f2x6-qh4w is a high-severity (CVSS 7.5) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
When using the TYPO3 backend in order to create new backend user accounts, database records containing insecure or empty credentials might be persisted. When the type of user account is changed - which might be entity type or the admin flag for backend users - the backend form is reloaded in order to reflect changed configuration possibilities. However, this leads to persisting the current state as well, which can result into some of the following:
- account contains empty login credentials (username and/or password)
- account is incomplete and contains weak credentials (username and/or password)
Albeit the functionality provided by the TYPO3 core cannot be used either with empty usernames or empty passwords, it still can be a severe vulnerability to custom authentication service implementations.
This weakness cannot be directly exploited and requires interaction on purpose by some backend user having according privileges.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.23 | 8.7.23composer require typo3/cms-core:^8.7.23 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.4 | 9.5.4composer require typo3/cms-core:^9.5.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rxc9-f2x6-qh4w is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rxc9-f2x6-qh4w in your dependencies?
Find it across Packagist, including transitive dependencies.