NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Uncontrolled Resource Consumption in @discordjs/opusGHSA-rvgf-69j7-xh78

HIGHFix: discordjs/opus@406249f

GHSA-rvgf-69j7-xh78 is a high-severity (CVSS 7.5) CWE-908 vulnerability in @discordjs/opus. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @discordjs/opus — see the affected versions and patch details below.

Also known asCVE-2022-25345
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.63%1.27%1.90%0.4%1.4%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

200other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@discordjs/opusnpm
92Kdownloads / week

Description

Improperly handled errors in @discordjs/opus cause hard crashes instead of returning the error to user land. All versions of package @discordjs/opus (<= 0.7.0) are vulnerable to Denial of Service (DoS) when trying to encode using an encoder with zero channels, or a non-initialized buffer. This leads to a hard crash due to improperly returning the errors from the invalid inputs.

As of version 0.8.0, the errors are correctly returned to the user and are no longer throwing hard crashes that cannot be recovered.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@discordjs/opusall versions0.8.0npm install @discordjs/opus@0.8.0

Affected Products

1 product · 1 configurations
Application
opusdiscordjs
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @discordjs/opus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @discordjs/opus to 0.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rvgf-69j7-xh78 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Improperly handled errors in @discordjs/opus cause hard crashes instead of returning the error to user land. All versions of package @discordjs/opus (<= 0.7.0) are vulnerable to Denial of Service (DoS) when trying to encode using an encoder with zero channels, or a non-initialized buffer. This leads to a hard crash due to improperly returning the errors from the invalid inputs. As of version 0.8.0, the errors are correctly returned to the user and are no longer throwing hard crashes that cannot be recovered.
O3 Security · Impact-Aware SCA

Is GHSA-rvgf-69j7-xh78 in your dependencies?

Find it across npm, including transitive dependencies.

Uncontrolled Resource Consumption in @discordjs/opus