TYPO3 Information Disclosure in Backend User InterfaceGHSA-rv8r-8mh5-5376
MEDIUMGHSA-rv8r-8mh5-5376 is a medium-severity (CVSS 5.4) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The element information component used to display properties of a certain record is susceptible to information disclosure. The list of references from or to the record is not properly checked for the backend user’s permissions. A valid backend user account is needed in order to exploit this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.27 | 8.7.27composer require typo3/cms-core:^8.7.27 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.8 | 9.5.8composer require typo3/cms-core:^9.5.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rv8r-8mh5-5376 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-rv8r-8mh5-5376 in your dependencies?
Find it across Packagist, including transitive dependencies.