NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Open Redirect vulnerability in jupyterhub and notebookGHSA-rv62-4pmj-xw6h

MEDIUMFix: jupyter/notebook@08c4c89

GHSA-rv62-4pmj-xw6h is a medium-severity (CVSS 6.1) Open Redirect vulnerability in notebook. A fix is available for notebook — see the affected versions and patch details below.

Also known asCVE-2019-10255PYSEC-2026-2683PYSEC-2026-647
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.50%2.26%0.5%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍notebook🐍jupyterhub

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An Open Redirect vulnerability for all browsers in Jupyter Notebook before 5.7.8 and some browsers (Chrome, Firefox) in JupyterHub before 0.9.6 allows crafted links to the login page, which will redirect to a malicious site after successful login. Servers running on a base_url prefix are not affected.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInotebookall versions5.7.8pip install --upgrade 'notebook==5.7.8'
🐍PyPIjupyterhuball versions0.9.6pip install --upgrade 'jupyterhub==0.9.6'

Affected Products

2 products · 2 configurations
Application
jupyterhubjupyter
< 0.9.5
range
Application
notebookjupyter
< 5.7.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for notebook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update notebook to 5.7.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rv62-4pmj-xw6h is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

An Open Redirect vulnerability for all browsers in Jupyter Notebook before 5.7.8 and some browsers (Chrome, Firefox) in JupyterHub before 0.9.6 allows crafted links to the login page, which will redirect to a malicious site after successful login. Servers running on a base_url prefix are not affected.
O3 Security · Impact-Aware SCA

Is GHSA-rv62-4pmj-xw6h in your dependencies?

Find it across PyPI, including transitive dependencies.

Open Redirect vulnerability in jupyterhub and notebook