Indico has a Cross-Site-Scripting during account creationGHSA-rrqf-w74j-24ff
MEDIUMFix: indico/flask-multipass@0bdcf65GHSA-rrqf-w74j-24ff is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in indico. A fix is available for indico — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-rrqf-w74j-24ff.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
indicoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
There is a Cross-Site-Scripting vulnerability during account creation when redirecting after the account has been successfully created. Exploitation requires the user to initiate the account creation process with a maliciously crafted link, and then finalize the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users so the benefits of exploiting it are very limited.
Patches
You should to update to Indico 3.3.4 as soon as possible. See the docs for instructions on how to update.
Workarounds
- If you build the Indico package yourself and cannot upgrade for some reason, you can simply update the
flask-multipassdependency to>=0.5.5which fixes the vulnerability. You would do that by editingrequirements.txtbefore building the package (see commit 7dcb573837), or possibly cherry-picking that particular commit. - Otherwise you could configure your web server to disallow requests containing a query string with a parameter that starts with
javascript:
For more information
If you have any questions or comments about this advisory:
- Open a thread in our forum
- Email us privately at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | indico | all versions | 3.3.4pip install --upgrade 'indico==3.3.4' |
Affected Products
indicocernDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for indico, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update indico to 3.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rrqf-w74j-24ff is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-rrqf-w74j-24ff in your dependencies?
Find it across PyPI, including transitive dependencies.