NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

XSS vulnerability in translationsGHSA-rrgw-3hg3-9x8c

MEDIUM

GHSA-rrgw-3hg3-9x8c is a medium-severity (CVSS 6.9) vulnerability in oro/platform. A fix is available for oro/platform — see the affected versions and patch details below.

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Dec 4, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

3 pkgs affected
🐘oro/platform🐘oro/platform🐘oro/platform

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

An attacker with admin privileges and access to Translations management functionality may add JS payload to translation values via:

  • Translation management UI.
  • Translations downloaded via the Crowdin service may also contain JS strings used for XSS attacks, for a successful attack poisoned translation should be enabled, downloaded, and installed.
  • Translations uploaded via Upload translation file on the All Languages grid

Workarounds

There are no workarounds that address this vulnerability.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoro/platform≥ 3.1.0&&< 3.1.293.1.29composer require oro/platform:^3.1.29
🐘Packagistoro/platform≥ 4.1.0&&< 4.1.174.1.17composer require oro/platform:^4.1.17
🐘Packagistoro/platform≥ 4.2.0&&< 4.2.84.2.8composer require oro/platform:^4.2.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oro/platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update oro/platform to 3.1.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rrgw-3hg3-9x8c is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary An attacker with admin privileges and access to Translations management functionality may add JS payload to translation values via: - Translation management UI. - Translations downloaded via the Crowdin service may also contain JS strings used for XSS attacks, for a successful attack poisoned translation should be enabled, downloaded, and installed. - Translations uploaded via Upload translation file on the All Languages grid ### Workarounds There are no workarounds that address this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-rrgw-3hg3-9x8c in your dependencies?

Find it across Packagist, including transitive dependencies.

XSS vulnerability in translations (Medium 6.9)