Magento sql injection vulnerabilityGHSA-rr59-pjwj-6grj
HIGHGHSA-rr59-pjwj-6grj is a high-severity (CVSS 7.5) SQL Injection vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have an sql injection vulnerability. Successful exploitation could lead to sensitive information disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.4 | 2.3.4composer require magento/community-edition:^2.3.4 |
| 🐘Packagist | magento/community-edition | all versions | 2.2.11composer require magento/community-edition:^2.2.11 |
| 🐘Packagist | magento/core | all versions | 1.9.4.4composer require magento/core:^1.9.4.4 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rr59-pjwj-6grj is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-rr59-pjwj-6grj in your dependencies?
Find it across Packagist, including transitive dependencies.