OS Command Injection in lifion-verify-depsGHSA-rphm-c8gw-3r38
HIGHFix: lifion/lifion-verify-deps@be1133dGHSA-rphm-c8gw-3r38 is a high-severity (CVSS 8.8) OS Command Injection vulnerability in lifion-verify-deps. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for lifion-verify-deps — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
lifion-verify-depsnpmDescription
lifion-verify-dependencies through 1.1.0 is vulnerable to OS command injection via a crafted dependency name on the scanned project's package.json file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | lifion-verify-deps | all versions | 1.2.0npm install lifion-verify-deps@1.2.0 |
Affected Products
lifion-verifiy-dependenciesadpResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lifion-verify-deps, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update lifion-verify-deps to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rphm-c8gw-3r38 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-rphm-c8gw-3r38 in your dependencies?
Find it across npm, including transitive dependencies.