Pagekit Weak Password Recovery Mechanism for Forgotten PasswordGHSA-rp89-32rp-qpq2
HIGHFix: pagekit/pagekit@e0454f9GHSA-rp89-32rp-qpq2 is a high-severity (CVSS 7.5) CWE-640 vulnerability in pagekit/pagekit. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for pagekit/pagekit — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pagekit/pagekitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Pagekit CMS before 1.0.11. In this vulnerability the remote attacker is able to reset the registered user's password, when the debug toolbar is enabled. The password is successfully recovered using this exploit. The SecureLayer7 ID is SL7_PGKT_01.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pagekit/pagekit | all versions | 1.0.11composer require pagekit/pagekit:^1.0.11 |
Affected Products
pagekitpagekitResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
PageKit 1.0.10 - Password Reset
by Saurabh Banawar · Jan 21, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pagekit/pagekit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pagekit/pagekit to 1.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rp89-32rp-qpq2 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rp89-32rp-qpq2 in your dependencies?
Find it across Packagist, including transitive dependencies.