GHSA-rm7c-x6gj-2mr8 is a medium-severity (CVSS 5.5) CWE-532 vulnerability in github.com/heketi/heketi. A fix is available for github.com/heketi/heketi — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/heketi/heketiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
An information-disclosure flaw was found in the way Heketi before 10.1.0 logs sensitive information. This flaw allows an attacker with local access to the Heketi server to read potentially sensitive information such as gluster-block passwords.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/heketi/heketi | all versions | 10.1.0go get github.com/heketi/heketi@v10.1.0 |
Affected Products
heketiheketi_projectenterprise linuxredhatgluster storageredhatopenshift container platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/heketi/heketi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/heketi/heketi to 10.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rm7c-x6gj-2mr8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The version of heketi shipped with Red Hat Gluster Storage 3 does not filter out gluster-block volume passwords, hence affected by this vulnerability.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-rm7c-x6gj-2mr8 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Native Client for RHEL 7 for Red Hat Storage | heketi-0:9.0.0-9.5.el7rhgs | RHSA-2020:4143 |
| Red Hat OpenShift Container Platform 4.7 | openshift4/ose-cluster-autoscaler:v4.7.0-202102130115.p0 | RHSA-2020:5633 |
Frequently Asked Questions
Is GHSA-rm7c-x6gj-2mr8 in your dependencies?
Find it across Go, including transitive dependencies.