NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Elliptic Uses a Broken or Risky Cryptographic AlgorithmGHSA-r9p9-mrjm-926w

MEDIUMFix: indutny/elliptic#244

GHSA-r9p9-mrjm-926w is a medium-severity (CVSS 6.8) Broken Cryptographic Algorithm vulnerability in elliptic. A fix is available for elliptic — see the affected versions and patch details below.

Also known asCVE-2020-28498
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.37%1.84%3.30%4.76%3.9%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ellipticnpm
16.6Mdownloads / week

Description

The npm package elliptic before version 6.5.4 are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmellipticall versions6.5.4npm install elliptic@6.5.4

Affected Products

1 product · 1 configurations
Application
ellipticindutny
< 6.5.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elliptic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update elliptic to 6.5.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r9p9-mrjm-926w is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The npm package `elliptic` before version 6.5.4 are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.
O3 Security · Impact-Aware SCA

Is GHSA-r9p9-mrjm-926w in your dependencies?

Find it across npm, including transitive dependencies.

Elliptic Uses a Broken or Risky Cryptographic Algorithm