Silverstripe XSS vulnerability via VirtualPageGHSA-r97r-64vp-fghm
MEDIUMGHSA-r97r-64vp-fghm is a medium-severity (CVSS 6.1) vulnerability in silverstripe/cms. A fix is available for silverstripe/cms — see the affected versions and patch details below.
Real-World Exposure
silverstripe/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site scripting vulnerability has been discovered in the VirtualPage class.
This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the textfields of a page which a VirtualPage refers to.
This has been resolved by ensuring that VirtualPage safely escapes all field content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/cms | ≥ 3.1.0&&< 3.1.10 | 3.1.10composer require silverstripe/cms:^3.1.10 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/cms to 3.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r97r-64vp-fghm is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-r97r-64vp-fghm in your dependencies?
Find it across Packagist, including transitive dependencies.