OpenClaw: Command-authorized non-owners could reach owner-only `/config` and `/debug` surfacesGHSA-r7vr-gr74-94p8
HIGHFix: openclaw/openclaw#44305GHSA-r7vr-gr74-94p8 is a high-severity (CVSS 8.8) CWE-863 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r7vr-gr74-94p8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
OpenClaw documented /config and /debug as owner-only commands, but the command handlers checked only whether the sender was command-authorized. A lower-trust sender who was intentionally allowed to run commands could still reach privileged configuration and debugging surfaces.
Impact
This allowed a non-owner sender to read or change privileged configuration that should have remained restricted to owners.
Affected versions
openclaw <= 2026.3.11
Patch
Fixed in openclaw 2026.3.12. Owner checks are now enforced for privileged command surfaces, and regression tests cover /config and /debug access control.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.3.12npm install openclaw@2026.3.12 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.3.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r7vr-gr74-94p8 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-r7vr-gr74-94p8 in your dependencies?
Find it across npm, including transitive dependencies.