Concrete CMS Stored XSS in the Custom Class page editingGHSA-r7q4-cw9r-vhp4
LOWFix: concretecms/concretecms#11988GHSA-r7q4-cw9r-vhp4 is a low-severity (CVSS 3.1) Cross-site Scripting (XSS) vulnerability in concrete5/concrete5. A fix is available for concrete5/concrete5 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r7q4-cw9r-vhp4.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
concrete5/concrete5🐘concrete5/concrete5Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Concrete CMS version 9 before 9.2.8 and previous versions before 8.5.16 are vulnerable to Stored XSS in the Custom Class page editing. Prior to the fix, a rogue administrator could insert malicious code in the custom class field due to insufficient validation of administrator provided data. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | concrete5/concrete5 | ≥ 9.0.0RC1&&< 9.2.8 | 9.2.8composer require concrete5/concrete5:^9.2.8 |
| 🐘Packagist | concrete5/concrete5 | all versions | 8.5.16composer require concrete5/concrete5:^8.5.16 |
Affected Products
concrete cmsconcretecmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for concrete5/concrete5, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update concrete5/concrete5 to 9.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r7q4-cw9r-vhp4 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-r7q4-cw9r-vhp4 in your dependencies?
Find it across Packagist, including transitive dependencies.