NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Magento Improper Authorization vulnerabilityGHSA-r7mm-grf3-5fjv

HIGHFix: magento/magento2@246d524

GHSA-r7mm-grf3-5fjv is a high-severity (CVSS 7.5) CWE-285 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Also known asBIT-magento-2022-34256CVE-2022-34256
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-r7mm-grf3-5fjv.

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk+0.06%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.92%1.84%2.75%0.4%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.7-p42.3.7-p4composer require magento/community-edition:^2.3.7-p4
🐘Packagistmagento/community-edition≥ 2.4.4&&< 2.4.52.4.5composer require magento/community-edition:^2.4.5
🐘Packagistmagento/community-edition≥ 2.4.0&&< 2.4.3-p32.4.3-p3composer require magento/community-edition:^2.4.3-p3

Affected Products

2 products · 20 configurations
Application
commerceadobe
≥ 2.4.0 && < 2.4.3
3 versions
2.3.72.4.32.4.4
Application
magentomagento
≥ 2.4.0 && < 2.4.3
3 versions
2.3.72.4.32.4.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.7-p4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r7mm-grf3-5fjv is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is GHSA-r7mm-grf3-5fjv in your dependencies?

Find it across Packagist, including transitive dependencies.

Magento Improper Authorization vulnerability (High 7.5)