Eclipse Jetty's PushSessionCacheFilter can cause remote DoS attacksGHSA-r7m4-f9h5-gr79
LOWFix: jetty/jetty.project#10755GHSA-r7m4-f9h5-gr79 is a low-severity (CVSS 3.1) Uncontrolled Resource Consumption vulnerability in org.eclipse.jetty:jetty-servlets. A fix is available for org.eclipse.jetty:jetty-servlets — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r7m4-f9h5-gr79.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-servlets☕org.eclipse.jetty:jetty-servlets☕org.eclipse.jetty:jetty-servletsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Jetty PushSessionCacheFilter can be exploited by unauthenticated users to launch remote DoS attacks by exhausting the server’s memory.
Patches
Workarounds
The session usage is intrinsic to the design of the PushCacheFilter. The issue can be avoided by:
- not using the PushCacheFilter. Push has been deprecated by the various IETF specs and early hints responses should be used instead.
- reducing the reducing the idle timeout on unauthenticated sessions will reduce the time such session stay in memory.
- configuring a session cache to use session passivation, so that sessions are not stored in memory, but rather in a database or file system that may have significantly more capacity than memory.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-servlets | ≥ 10.0.0&&< 10.0.18 | 10.0.18org.eclipse.jetty:jetty-servlets:10.0.18 |
| ☕Maven | org.eclipse.jetty:jetty-servlets | ≥ 11.0.0&&< 11.0.18 | 11.0.18org.eclipse.jetty:jetty-servlets:11.0.18 |
| ☕Maven | org.eclipse.jetty:jetty-servlets | ≥ 12.0.0&&< 12.0.4 | 12.0.4org.eclipse.jetty:jetty-servlets:12.0.4 |
Affected Products
jettyeclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-servlets, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-servlets to 10.0.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r7m4-f9h5-gr79 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-r7m4-f9h5-gr79 in your dependencies?
Find it across Maven, including transitive dependencies.